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While Deltek has attempted to verify that the information in this document is accurate and complete, some 

typographical or technical errors may exist. The recipient of this document is solely responsible for all decisions 

relating to or use of the information provided herein. 

This publication contains proprietary information that is protected by copyright. All rights are reserved. No part 

of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, or 

translated into another language, without the prior written consent of Deltek, Inc. 

© Deltek, Inc. 

Deltek’s software is also protected by copyright law and constitutes valuable confidential and proprietary 

information of Deltek, Inc. and its licensors. The Deltek software, and all related documentation, is provided for 

use only in accordance with the terms of the license agreement. Unauthorized reproduction or distribution of 

the program or any portion thereof could result in severe civil or criminal penalties 

All trademarks are the property of their respective owners. 
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Costpoint Extensibility Designer Quick Start Costpoint Extensibility Designer Quick Start 
Guide Guide 
Introduction Introduction 

This quick start guide is designed to help you learn the basic steps in creating and deploying extensibility. Refer 

to other documentation for deeper or more detail discussion of the subject. 

▪ Deltek Costpoint Extensibility Designer User Guide: Navigating and using the Extensibility Designer to create 
Costpoint extensions 

▪ Deltek Costpoint Screen Customization and Business Logic Extensibility: Concepts and features of Costpoint 
extensibility 

▪ Deltek Costpoint Extensibility Designer Coding Guide: Creating business logic extensions with stored 
procedures and java classes 

General Steps Overview General Steps Overview 

There are 12 general steps for creating and deploying an extension, divided into the following categories: 

▪ Checking requirements and setting up 

▪ Creating the extension 

▪ Testing the extension 

▪ Packaging the extension 

▪ Deploying the extensibility package to another system 

▪ Verifying the Deployment to the system 

Check the Requirements and Set Up Extensibility Check the Requirements and Set Up Extensibility 

Step Step Description Description 

1 License Requirement. 

2 Enable System for Extensibility 

3 Enable Costpoint user for Extensibility Designer 
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Create the Extension Create the Extension 

Step Step Description Description 

4 Log In to Extensibility Designer 

5 Create a project 

6 Create a unit for the project 

7 Create an extension 

Test the Extension Test the Extension 

Step Step Description Description 

8 Test the Extension 

Package the Extension Package the Extension 

Step Step Description Description 

9 Run Export Script 

10 Package the Extension 

Deploy the Extensibility Package to Another System Deploy the Extensibility Package to Another System 

Step Step Description Description 

11 Run DBWizard tool to deploy the extensibility package 

Verify the Deployment to the System Verify the Deployment to the System 

Step Step Description Description 

12 Repeat “Step 8: Test the Extension” to verify the extension was successfully deployed to the system in 

Step 11. 

Step 1: License Requirement Step 1: License Requirement 

You must have the license for Extensibility in order to use the tool. 
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To verify that you have the Extensibility license: To verify that you have the Extensibility license: 

1. In Costpoint, open the View Costpoint License Information application. 

2. In the Licensed Added-On ModulesLicensed Added-On Modules grid, verify that there is an entry for Extensibility. 

Step 2: Enable System for Extensibility Step 2: Enable System for Extensibility 

To enable the system for extensibility: To enable the system for extensibility: 

1. Start the Costpoint Configuration Utility by running CPWebConfigUtility.cmdCPWebConfigUtility.cmd located on the application 
server in the \deltek\costpoint\82\bin folder. 

Note:Note: Make sure the server is running before you start this utility. 

2. Select to configure Costpoint Application Configuration. 

3. When the Costpoint Configuration Utility screen displays, perform the following: 

a. Click the Systems tab. 

b. From the Displaying SystemDisplaying System drop-down list, select the appropriate system. 
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c. Click the Extensibility tab. 

d. Click EnabledEnabled to enable the system for extensibility. 

Step 3: Enable Costpoint User for Extensibility Designer Step 3: Enable Costpoint User for Extensibility Designer 

To enable a Costpoint user for the Extensibility Designer tool: To enable a Costpoint user for the Extensibility Designer tool: 

1. In the Costpoint system selected in Step 2, open the Manage Users application. 

2. Query and select a user that will be using the Extensibility Designer. 

3. On the Authentication tab, select the Allow Access to Extensibility ConsoleAllow Access to Extensibility Console checkbox. 
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This user can now log in to the Extensibility Designer with their Costpoint user ID and password. 

Note:Note: This procedure does not change any security rights for the user within Costpoint. It only allows this user to 

log in to the Extensibility Designer in order to create customization work. 

Step 4: Log In to Extensibility Designer Step 4: Log In to Extensibility Designer 

To log in to the Extensibility Designer: To log in to the Extensibility Designer: 

1. Start the Extensibility Designer by running CPWebExtDesigner.cmdCPWebExtDesigner.cmd located on the application server in the 
\deltek\costpoint\82\bin folder. 

2. On the Deltek’s J2EE Application Designer – Login dialog box, enter the UserUser ID and PasswordPassword for the user 
enabled in Step 3. 

 

3. Click LoginLogin. 
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If the user is not enabled to use the Extensibility Designer, the following message displays. 

Step 5: Create a Project Step 5: Create a Project 

A project is an umbrella under which the units created for the project reside. A project does not contain any 

logic except for tracking and grouping the work done in the Extensibility Designer. A project helps differentiate 

work done by different companies in case you have contracted customization work out to third-party 

companies. 

To create a new project: To create a new project: 

1. Click the NewNew icon, and then click Extensibility ProjectExtensibility Project on the shortcut menu, or click Object » New » Object » New » 
Extensibility ProjectExtensibility Project. 

 

2. On the New Extensibility Project dialog box, enter the following information: 

▪ IdId: Enter an unique ID for the extensibility project. Cloud Clients must include the five-digit customer ID 
number after the XT_XT_ prefix. This field is required. 
Note:Note: All extensibility project IDs must begin with 'XT_'. All new extensibility objects inside this project 
will have this project ID as prefix. This separates extensibility objects from regular objects and helps track 
what objects belong to what project. 
Each extensibility project ID must be unique. This ensures that customers can apply multiple extensibility 
projects to their environments. 
Cloud ClientsCloud Clients: If you do not follow the required naming format, your extension request will be rejected. 

▪ NameName: Enter the unique name for the new project. This informational descriptor is a required field and is 
limited to a total of 13 characters. 
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Note:Note: You should enter some text describing the purpose of the Projects into the notes field. It is a free-
form text field. 

 

3. Click OkOk to save. 

4. When asked to create the folder to contain the files for this project, click YesYes. 

 

The location for the files is not critical as long as the structure starting with \com\\com\ is preserved. In this case, the 

structure is: 

\com\deltek\enterprise\extensions\xt_12345AAAAAxt_12345AAAAA\dbscripts\admin, where xt_12345AAAAAxt_12345AAAAA is the project ID 

If you develop java classes as part of the extension, the application expects the java package to follow this 

naming convention, so every package will have unique name. 

Step 6: Create a Unit for the Project Step 6: Create a Unit for the Project 

An Extensibility Unit contains a set of changes to applications, screens, reports, or processes to be assigned as a 

whole to user(s) or user group(s) inside Costpoint. If there are different changes to be applied to different users 
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or groups, they should be implemented in separate units. 

To create a new unit for a project: To create a new unit for a project: 

1. Click the NewNew icon, and then click Extensibility UnitExtensibility Unit on the shortcut menu, or click Object » New » Object » New » 
Extensibility UnitExtensibility Unit. 

2. On the Select Extension Project dialog box, select the project that will contain this unit, and click NextNext. 

 

3. On the New Extensibility Unit dialog box, enter the Unit IdUnit Id and NameName. 

A unit ID always starts with the Project ID. 

4. In the text field, enter the description of the unit as applicable. 
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5. Click OkOk. 

Step 7: Create an Extension Step 7: Create an Extension 

The Extensibility Designer allows you to extend the functionality of an existing result set (a subtask within an 

application), an action (process), or a report. You can also add brand new Result Set (subtask), action, report, 

message text, or constants to be used in the extended result set, report, or action. You can even create a brand 

new custom Application with any number of subtasks. 

Each screen in an application is called result set (RS). In any screen, you can change field labels, field status text, 

and/or field position. You can change the behavior of a field such as non-required to required, visible to not 

visible, and so on. You can also add additional data fields to the screen. 

To extend a result set: To extend a result set: 

1. Click Extensions » Extend » RSExtensions » Extend » RS. 

2. Select the project and unit in which to create the extension. 

3. On the Select RS dialog box, select the result set to extend. 
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Note:Note: Use the RS Wild CardRS Wild Card field to filter the list of result sets based on the RS ID. Generally, the RS ID 
starts with the application ID. For example SYMUSR_WUSERUGRLIST is the top level result set for the 
SYMUSR application (Manage Users). 

4. Click NextNext. 

5. On the Edit Result Set dialog box, customize the result set. 

 

You can use this dialog box to customize the following: (see Extensibility Designer User Guide for details) 

▪ Change RS title 

▪ Register a stored procedure or additional java classes to be called after Costpoint executes the standard 
logics. You will need to create the stored procedure or java classes. 

▪ Enable email notifications when certain events happen to the data. 

▪ Add additional data fields 
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▪ Change certain attributes for existing fields such as Visible, Editable, Required, Default Value, labels, 
status text, and so on. 

Attention:Attention: See the Deltek Costpoint 8.2 Extensibility Designer User Guide for more information. 

Example Example 

The following example changes the email ID field in the Maintain User application from Non-requiredNon-required to 

RequiredRequired. 

To create a result set extension: To create a result set extension: 

1. On the Edit Result Set dialog box, click the RS Description tab. 

2. Browse the Object IdObject Id list in the left panel and select U_EMAIL_NAMEU_EMAIL_NAME (the Email Name field). 

Note:Note: Object IDs on this panel are ordered alphabetically. Object IDs are created by Deltek, so they are not 
changeable. They are usually named after the column name in the database. 
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3. To make sure this is the correct object, complete the following steps: 

a. Click the RS Presentation tab. 

b. In the Object IdObject Id list, select U_EMAIL_NAMEU_EMAIL_NAME. 

Objects in this list are generally ordered in the same sequence as the order of columns in table view when 
viewed in Costpoint. 

c. Verify that the Form LabelForm Label, Table LabelTable Label, and Status TextStatus Text fields contain the appropriate text. 

These are the labels and status text displayed for this field when you are in Costpoint. 

 

4. Click the RS Description tab. 

5. In the RequiredRequired drop down list, select YesYes. 

6. Click the RS Presentation tab. 

7. Change the Status TextStatus Text to “Enter the email address. This is a required entry.” 

Notice that any changes you make are highlighted in yellow, so you can quickly identify what you have 
changed. 

Costpoint Extensibility Designer Quick Start Guide 12



 

 

8. Click OKOK to save and close the result set extension. 

Step 8: Test the Extension Step 8: Test the Extension 

To test the extension: To test the extension: 

Note:Note: This procedure verifies the result set extension created in the example for the previous step. 

1. Log in to Costpoint as Administrator, and go to the Manage Extensibility Units application. 

2. Verify that the unit is available and the ValidValid flag is YY, and then click the ApplicationsApplications subtask to make sure 
the application(s) shown is correct. 
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3. In the Manage User Interface Profile application, create a UI profile. 

4. Each profile must have a different PriorityPriority number. 

This number is in case changes are made to the same screen from different units and happen to assign to 
the same user. The system will resolve this by aggregating the changes. However, some changes cannot be 
aggregated if they are made on the same object. In such a case, the system will select the changes from 
the one with the highest priority. 

 

5. Assign the profile to a user group or groups or to a particular user as applicable. 

Note:Note: The extensibility feature will only be seen and executed for the user(s) assigned to this profile. If the 
profile applies to everyone, assign it to the group EVERYONEEVERYONE. 

6. Click the Extensibility UnitsExtensibility Units subtask, and assign the unit to this profile. 
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7. Save the profile. 

8. Log off and log in to Costpoint with the user ID assigned to the UI profile that contains the extensibility 
changes. 

9. Go to the application that has been customized. In this example, the Manage Users application was 
customized. 

10. Verify that the Email NameEmail Name field is now marked as required (with the red asterisk) and the status text at the 
bottom has been customized with the additional message. 

Now, when saving a record without an Email NameEmail Name entry, an error message displays. 

Step 9: Export Script Step 9: Export Script 

Exporting script is needed if you are creating the extension in a design/development system and want to deploy 

the extension to a second system (for example, QC or production). 

To export the result set extension script for deployment to another system: To export the result set extension script for deployment to another system: 

1. From the Extensibility Designer main menu, expand the Extensibility ProjectsExtensibility Projects folder, and select the 
appropriate project. 

2. Click Extensions » Export ScriptExtensions » Export Script. 
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3. When a dialog box displays confirming the location of the folder where script files will be created, click OKOK. 

Note:Note: This folder was created when you created the project. 

4. When a message displays confirming the data has been exported to a SQL file, click OKOK. 

Step 10: Package the Extension Step 10: Package the Extension 

You need to package the extension if you create the extension in a design/development system and want to 

deploy the extension to a second system (for example, QC or production). 

To package an extension for deployment to another system: To package an extension for deployment to another system: 

1. From the Extensibility Designer main menu, click Tools » Extensibility PackagerTools » Extensibility Packager. 

The Extensibility Projects Packager dialog box displays with a list of projects created in this system. 
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2. Select the project to package. 

The location and name of the zip file to be created displays at the bottom of the dialog box. 

3. Click PackPack. 

A progress dialog box displays, showing the log. 

4. Click CloseClose when done. 

5. Navigate the folder where the extension zip file was created and verify that it is there. 

Step 11: Deploy the Extensibility Package Step 11: Deploy the Extensibility Package 

To deploy the extensibility package: To deploy the extensibility package: 

1. On the application server machine for the system where the package is to be deployed, launch the 
DBWizard tool by running CPWebDBWizardCPWebDBWizard. in the \deltek\costpoint\82\bin folder. 

Note:Note: Presumably, this is the QC or production server that is different from the server used for developing 
the extension. 

2. On the Costpoint DB Wizard screen, click Deploy ExtensionsDeploy Extensions. 
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3. On the Deploy Extension screen, select the system on which to deploy the package 

 

4. Browse and select the extensibility zip file created in Step 10. 
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5. Optional. If your package contains a stored procedure, create tables, views, or other database objects SQL 
scripts to be applied, select the Deploy Custom DB ScriptsDeploy Custom DB Scripts check box. 

6. Click Next » RunNext » Run to deploy the package. 

If the Extension contains Java classes, the Weblogic server (or all Weblogic nodes if given deployment has 
more than 1 server) needs to be restarted to make changes to Java side effective. 

Step 12: Verify the Deployment to the System Step 12: Verify the Deployment to the System 

To verify that the extension was successfully deployed, repeat “Step 8: Test the Extension” for the system in 

Step 11. 

When completed, the extension is ready and active. 

Note:Note: If you have application Extensions, Deltek recommends deploying the application or system hotfixes first 

to your testing environment where you can verify that the hotfix did not change the application in a significant 

manner, making your Extensions no longer valid or usable. Even though the DBWizard has built in logic to check 

each Extension Unit against the standard application, some features like screen layouts or your business Java or 

Stored Procedure plug-ins can be verified only by testing. 
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